TSRI

MGLTools

Documentation‎ > ‎Tutorials‎ > ‎Written Tutorials‎ > ‎

3. Advanced ePMV tutorials

Load a volumetric file

In this case we'll load a 3D density map of a Nuclear Pore Complex (NPC) derived from single-particle Electron Microscopy
  1. Visit the Electron Microscopy Data Base
  2. Click Basic Search
  3. Type nuclear into the Title box on the search page and hit the [start search] button
  4. Click on entry 1097
  5. Click Map Information
  6. Click to download then unzip emd_1097.map.gz
  7. CHANGE emd_1097.map to emd_1097.ccp4 (bug in PMV doesn't recognize the .map tag)
  8. Open ePMV
  9. [If using ePMVv0.4.5 or newer, skip this step] Load a molecule, e.g., 1crn to trigger needed functions (temporary glitch fixed in 0.4.5)
    1. This dummy molecule need not be visible, but its good to leave on to get an idea of the major scale differences between a tiny protein like 1crn (crambin) and your relatively large Nuclear Pore Complex
  10. Unfold DataPLayer
  11. In Data Player panel, Browse to your .ccp4 file to load it
  12. Since the EMDB file should be formatted with proper headers, the map should load at a correct scale compared to any molecules in the scene (often shockingly large)
    1. Its wise to confirm this scale simply by making a scale bar with a cube that is the length of your EMDB molecule (find dimensions of that molecule with a web search or by asking your content expert)
  13. Zoom out to see your nuclear pore complex surface map.
  14. Click the dropdown menu to select your molecule:
    1. Apply [yourEMDBimport] to ... and play below:
    2. This will trigger the slider box to update to an appropriate scale and range
  15. Adjust your slider to approximately 3 (better to type then to slide since this is a large file, but play around if you've saved your work in all open files)
  16. Now you can center the molecule to the origin, generate a large sphere to mock up a nucleus, and I'll show you how to map the nuclear pore to your fake sphere nucleus in a separate tutorial for Cinema 4D.


Populate a mock nuclear surface with NPCs

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)
  1. Generate a 3D isocontoured surface model using ePMV in the 1st part of this tutorial
  2. Reduce the Polygon Count on your molecule
    1. C4D top menu Object>Deformer>PolygonReduction
    2. In the Object Manager panel, drag the new PolygonReduction deformer onto 'yourLoadedDummyMoleculeName'IsoSurface to make it a child of yourLoadedDummyMoleculeName'IsoSurface
    3. Right click on 'yourLoadedDummyMoleculeName'IsoSurface and select Current state to object
    4. After the new object is created below the original, delete the original (and its child Polygon Reduction Deformer
    5. Select your reduced polygon mesh in the Object Manager
    6. Click on the PointTool button (in the left-most palette in C4D's default layout)
    7. Hover in the viewport and Select all of the points Command A on a mac, Control A on a PC
    8. In the Coordinates manager, set all values to zero and click [Apply]
    9. In the Coordinates manager, type -90 in the H box and -300 in the Y box and click [Apply]
    10. C4D top menu Object>Primitive>Sphere
    11. With the sphere selected, in the attributes manager, change Radius=8000, Segments=3, and Type=Icosohedron
    12. Double click the sphere in the object manager to change its name to mockNucleusOuterMembrane
    13. C4D top menu Mograph>Cloner
    14. With Cloner selected, set Mode=Object and drag mockNucleusOuterMembrane sphere from the object manager into the Object box in the Cloner attribute manager
    15. In the object manager, drag yourLoadedDummyMoleculeName'IsoSurface onto the Cloner to make it a child of the cloner.
    16. Click on Cloner and change Distribution=Surface
    17. Click on mockNucleusOuterMembrane and change segments=24
    18. Create a new material and drag it onto mockNucleusOuterMembrane
      1. Hack a hole into the outer membrane
        1. Double click the material name to change it to Nuc
        2. Double click the mockNucleusOuterMembrane material icon to open the Material Editor
        3. Check the [ ] Alpha box and in the Alpha box details:
          1. Check [ ] Invert
          2. Set the Texture pulldown menu to Effects>Proximal
          3. Click Proximal (spherical gradient box) to edit its details in the Material Editor Alpha
          4. Drag Cloner from the object manager into the big Objects area box
          5. Set Start Distance=410 and End Distance=500
    19. Render your scene
    20. Play with adding bump maps with noise and transparency, etc.
    21. Try adding a Displacer Deformer as a child of mockNucleusOuterMembrane with noise scaled to ~3000 and height to ~200 to make the sphere more organic.
    22. This works fine for mocking up a nuclear membrane, from outside of the nucleus, but recall that its actually a double membrane (like a continuous spherical Endoplasmic Reticulum that is fenestrated by the nuclear pores.
      1. If you plan to fly close to or inside of your nucleus you may need to temporarily replace your pores with cylinders, duplicate the sphere and reduce that spheres radius to mock the inner bilayer, then boolean to remove the spheres, etc.


Morphing between two conformers using the pathways.asu.edu server

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)
We will soon automate much of this process and tie into the Yale Morph Server as a second option, but in the mean time follow these steps to complete your project as accurately and cleanly as possible. This is a labor intensive path that we'll soon offer at the click of a button, but only takes about an hour from start to finish.
    1. You'll need two conformations of the same molecule or of related molecules. Its wise and more predictable if you clean up the files a bit first- use a text editor to remove everything but the ATOM entries for the particular chains you want to morph.  For this tutorial from a project for Bonnie Scott, download these two sample files:
      1. 2BYVe.pdb
      2. 3CF6eALN2.pdb
      3. I've cleaned the files and retained only chain E from both (deleted chain R from 1xyz and all of the HetAtoms and Remarks, etc.)
    2. Visit http://pathways.asu.edu/
      1. Beware, that as of May 2014, I can no longer access the pathways.asu.edu server. It appears that the project has been absorbed by http://www2.molmovdb.org/wiki/info/index.php/Morph_Server
        1. Please try http://www2.molmovdb.org/ until I can find out what is going on.
      2. Either register or click on guest in the middle of the page
      3. We will morph 3CF6eALN2.pdb as the initial structure onto 2BYVe.pdb as the final structure, so upload the files accordingly
      4. Click [Submit] and wait "one moment" until it finishes analyzing the input files
      5. Click [Run] and go have lunch
      6. When the run is complete (10-30 minutes) or (if you're bored and gets below .5Å RMSD click stop):
        1. Go to the Output File > Section and download the .zip file (you may have to [Create .zip] first which take several seconds.
    3. You should end up with a Pathways folder in your downloads that has ~173 snapshot files in it with names like 3CF6eALN2_FH_RCD_snapshot_00000173.pdb
    4. Concatenate the files in a multi-model PDB file format that ePMV will recognize
      1. Select Snapshot 1, 40, 80, 120, and 173 or a similarly spaced set depending on how many files you have and drag them all into TextEdit on a mac or NotePad on Windows or some equivalent text editor that allows you to save plaintext files.
      2. Use Snapshot 1 as a base and paste in the other files as follows:
        1. At the start of the file, before the first ATOM entry, paste:
          1. EXPDTA    SOLUTION NMR                                                          
          2. MODEL        1                                                                  
          3. Then leave the entire collection of ATOMS
        2. At the end of the last line that reads ATOM  10136  HD3 PRO E 990     -17.809 -36.917  50.791  0.00 28.00           H  , paste:
          1. TER   10137      PRO E 990                                                      
          2. ENDMDL                                                                          
          3. MODEL        2    
          4. Then select all of the text from the Snapshot40 file and paste it in
        3. Repeat step two changing the model number each time until you have all 5 snapshots in one file
        4. At the very end of the file, ATOM  10136  HD3 PRO E 990     -17.350 -35.011  50.760  0.00 28.00           H  , paste
          1. TER   10137      PRO E 990                                                      
          2. ENDMDL                                                                          
          3. END                                                                             
        5. Your file should look similar to this one in structure- the atoms may be different: 3CF6e_multi_1_173.pdb
          1. Open them side by side to compare, and if the following steps fail with your file, use the downloaded version and then investigate the text to see what is different.
    5. Restart your host, e.g, Cinema 4D in this case
    6. Start a fresh ePMV session
      1. In the ePMV menu click Edit>Options
        1. Uncheck [ ]Center Molecule
      2. Fetch 3CF6e_multi_1_173.pdb from your hard drive
      3. Unfold Backbone Representations
        1. Uncheck [ ]Ribbons
        2. Check [√]Loft
      4. Unfold Data Player
        1. Reselect 3CF6e_multi_1_173.pdb 
          1. Your data scroll bar should reset to zero
          2. Slowly click through to see all 5 conformations
        2. Uncheck [ ]Loft
        3. Unfold Surface representations 
          1. Check [√]CoarseMolSurf
          2. Slowly click through to see all 5 conformations
    7. Animate the conformational change:
      1. This is a HACK WORKAROUND until we fix a bug in our epmvSynchroTag, so stay tuned for the easier animation method
      2. You could do a PLA, morph target, or posemorph animation on the Polygon object in the loft to animate it morphing nicely with a similar approach but here we'll animate an Atomic CPK version of the model.  Once we fix a bug, you can animate through the cMS and MSMS versions while retaining chemical colors as well!, but more on that in a couple weeks.
      3. Uncheck all representations you had shown and check [√]Atoms 
      4. Zoom your molecule in the Right View panel as this best shows the conformational shift
        1. Color By: Per residue to color each side chain so you can watch the rotamers spinning easily
        2. Unfold the molecule in the hierarchy until you can see 3CF6e_multi_1_173:E_cpk
          1. Right click on 3CF6e_multi_1_173:E_cpk and click SelectChildren
          2. Command click 3CF6e_multi_1_173:E_cpk to deselect it so only the atom instances are selected
          3. Go to Frame 0 in your timeline
          4. Set the Data Player step/value box to 0
          5. In the palette to the right of your keyframe buttons, deselect Scale, Rotation, and Parameter, so only Position is blue
          6. Record a Keyframe (orange button to the right of the VCR controllers in the C4D Standard Layout)
            1. This will record a position key for every atom
          7. Go to Frame 5 in your timeline (advance 5 frames each time)
          8. Set the Data Player step/value box to 1
          9. Record a Keyframe
          10. Repeat steps 7 and 8 until you record
          11. Set the length of your scene to 25 frames by changing 90 F to 25 F in the box to the left of the VCR controllers in C4D
      5. Render the movie (settings here are specific to C4D):
        1. Click Render settings:
          1. On the Output Tab: 
            1. Change Preset to 640x480
            2. Change Frange to All Frames
          2. On the Save Tab:
            1. Set a File location with the browser button to the right of FIle...
            2. Change Format to Quicktime and Options to H.264 with a compression ~60
          3. Click the [Effect] button and add Ambient Occlusion
            1. In the Ambient Occlusion Tab that now appears, reduce accuracy to 20%, Min Samples to 8 and Max Samples to 32
          4. Click the RenderInPicutreViewer button in the main C4D GUI- your movie should look like this:
          5. YouTube Video



Working with Selections

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)
Making sensible selections in ePMV gives you great power and control- they are a bit tricky to understand, but follow this tutorial closely to get started on the path to advanced usage. You can select and visualize individual/ranges of atoms, residues, atom types, manual atomic selections made in the host, etc.
The new [ ]Show selection box in v0.5.2 makes selections relatively intuitive as long as you follow a few specific protocols.
The PMV selection syntax page describes the rules needed to make sophisticated text selections.
  1. Selections Quick and Dirty:
    1. Update ePMV to 0.5.2
    2. Open ePMV and click fetch to get 1crn
    3. Zoom in to see your whole molecule (In C4D, hover mouse over viewport and type "h" on keyboard)
    4. Check the [√] Show box in Selections
      1. You should see a point cloud of white +s for each atom in 1crn
    5. Make a selection with the keywords drop down menu
      1. e.g., "backbone", only the backbone +s should show
    6. Check [√] CoarseMolSurface, your entire molecule will get a Coarse Molecular Surface
    7. Alter any CoarsMolSurf parameter to update the mesh to match the current selection, i.e., to match the + marked atoms in the viewport
      1. Click in one of the boxes, e.g., put your cursor into the isovalue box and hit return
        1. You should only see a coarse molecular surface of the entire backbone of 1crn, but not the side chains
      2. Set Isovalue = 5, resolution = -5, and grid size = 100
        1. You should get a very nice backbone worm
      3. Set Color by scheme: [Rainbow from N to C]
        1. Render to see a rainbow gradient along your molecule
    8. Practice: 
      1. Make a new selection, e.g., "aromatics"
      2. Update the CMS by hitting return or adjusting a one of the parameters for cMS like isovalue if you don't mind changing the parameters from your nice settings
    9. Now, you can copy and paste the Mesh from your hierarchy
      1. Select CoarseMS_1crn in the object manager, copy and paste it, then move it to the bottom of your object manager on the top level
      2. Rename your pasted to meshCoarseMS_1crn_backboneRainbow1 or meshCoarseMS_1crn_aromatics1 (something relevant to your latest practice mesh)
      3. Continue to alter the main mesh manually like this to produce copies of the mesh you like by manually duplicating them, or you can do it properly with the ePMV GUI as described in the next section.
  2. Proper Selections with the ePMV GUI:
    1. Quit C4D and start a fresh session
    2. Open ePMV and fetch 1crn
    3. Check [√] Show box in Selections so you can see the effects of your actions with the selection tools
    4. Check [√] Atoms and then uncheck [ ] Atoms 
      1. This will build atoms into the object manager so we can make easy selections and then hide them so they don't obscure or slow the viewport.
    5. Lets select a range of residues
      1. Paste 1crn:A:TYR44-ASN46 into the selection box 
        1. This uses a PMV-specific selection syntax with Molecule:ChainID:ResidueOrResidueRange:Atom(s)
          1. See the PMV selection syntax page for extensive options
        2. You should see white +s for the 3 residues at the C terminus of 1crn
    6. Click [SaveSet] to the right of the selection box
    7. Set CurrentSelection: to [1crn_Selection0]
    8. Make a Coarse Molecular Surface (cMS) for practice, and update it as follows:
      1. Under Surfaces check [√] CoarseMolSurf
        1. You'll see a cMS of your entire molecule
      2. Click in one of the boxes, e.g., put your cursor into the isovalue box and hit return
        1. You should only see a cMS of only your three residues
      3. Set Isovalue = 5, resolution = -5, and grid size = 100
        1. You should get a very shape for your three residues
      4. Set Color by scheme: [Per residue]
        1. Render to see 3 different residue colors as a cMS mesh at the terminus of your default ribbon representation
      5. Uncheck [ ] CoarseMolSurf to hide the cMS
    9. Make an MSMS and update it as follows:
      1. Under Surfaces check [√] MSMSurf
        1. You should only see an MSMS of your three residues, but if you see the entire molecule, click in the probe radius box and hit return to update the mesh.
      2. Set Color by scheme: [Per residue]
        1. Render to see 3 different residue colors as an MSMSurf mesh at the terminus of your default ribbon representation
    10. Making selections via the GUI in a more intuitive fashion:
      1. We turned on the atoms in the beginning for a reason, lets highlight residues N14, I35 and A45 as follows:
        1. Set CurrentSelection: to [1crn]
        2. In the Object Manager, unfold 1crn, 1crnA, and 1crnA_CPK to reveal the atoms
        3. Use a combination of shiftSelect and commandSelect to select all of the atoms for the residues above, e.g.:
          1. In the object manager, shift select S.0.0.A45.CB.318 through S.0.0.A45.N.314 then hold the command key on a mac and select the other two sets further down in the hierarchy, you should have three point clouds in your viewport of +s for the three residues 45, 35, and 14, a total of 21 atoms
        4. Set Add selection using set or string to [picked]
          1. You should see your 21 selected atoms get white +s in your viewport
        5. Select [SaveSet] button to the right
        6. Manually hide your previous mesh of TYR44-ASN46 so you can see what happens to residue 45
          1. In the object manager, for MSMS-MOL1crn_Selection0 set the top and bottom visibility dots from grey to red
        7. In the ePMV GUI set CurrentSelection: to 1crn_Selection1
        8. Check [√] MSMSurf
          1. Here you'll encounter a difficulty- only the first residue gets meshed
          2. (WARNING: this next step may crash C4D on certain system setups, so feel free to skip this demo step and skip to the cMS Hack workaround that follows in step 9)
          3. Crank your probe radius to ~6.5
            1. You'll see that the others get meshed, but the MSMS algorithms (same algorithm that PMV, Pymol and Chimera use) isn't typically used to mesh individual sets of isolated atoms and you'll get an unconventional mesh, biologically meaningless with such a large probe radius
            2. To solve this, you'd have to either do it manually, or run the perResidue script with the complex selection set you just made pasted into the script by copying from the selection box after setting current selection to 1crn_Selection1 (ePMV builds the complex PMV syntax you need to do this.
          4. You can do a hack workaround as described here:
          5. Uncheck [ ] MSMSurf
        9. Check [√] CoarseMolSurf
          1. Update the mesh by clicking in the isovalue box and hitting return
            1. If you have the default isovalue settings, 7.5, -0.3 and 32, you should see a couple of small blobs near residue 14 and 35
              1. In this case some of the atom clusters are too small to generate a mesh with the default parameters... with the default
              2. Set the isovalue = 3.4, resolution =  -3.2, and grid size = 60
                1. You should see a cMS that starts to look like an MSMS for all three residues. 
          2. Manually turn the visibility of your MSMSurf for TYR44-46 back on (set the visibility dots from red to grey in the object manager),
          3. Adjust the CMS parameters for your 1crn_Selection1 until the cMS for 45 closely matches the MSMSurf for 45. Color by residue and you've got a fake MSMSurf made out of the cMS mesh.
        10. If you select consecutive residues or domains, or at least residues that have atoms within the probe radius, you won't have to jump through all these hoops.
        11. Post on the forum or email us if you get stuck
  3. DNA Selection Strings with the ePMV GUI:
    1. Restart your host and open ePMV
    2. Make DNA with the sequence of your choice following the online ePMV DNA builder tutorial section
      1. Be sure to set the name of your DNA to myDNA.pdb or otherwise use a consistent name for the rest of this tutorial where myDNA=yourDNAname
    3. Choose the representation style of your choice- here we have checked [√]Atoms
    4. Color the DNA with the preset of your choice:
      1. Color By Scheme: Choose a setting
      2. We have used Custom Color set to a very light grey
    5. To color code the the backbone:
      1. Set Selections>CurrentSelection: myDNA
      2. Check [√]Show
      3. Paste the following into the selection string
        1. myDNA:A,B::P,O1P,O2P,O5',C5',C4',O4',C3',O3',C2',C1'
          1. This will select all of the backbone atoms of both Chains of DNA in your model as indicated by white +s in the screen grab
      4. Color By Scheme: Custom
        1. Set a color
    6. In this screengrab we checked Atoms for the entire DNA model and set a white custom color.  We then Set the backbone atoms to orange.  In the host Cinema 4D, this provided two new materials that we can easily edit to modify these colors independent of the ePMV GUI.

    7. This screenshot shows all of the steps at once.

      Ugly colors (sorry) to quickly demonstrate: 1) Color By Residue, 2) Color Backbones as in tutorial, 3) Color backbone A using this modified selection string after coloring both backbones myDNA:A::P,O1P,O2P,O5',C5',C4',O4',C3',O3',C2',C1'

Molecular Dynamics using Modeller with an IK chain controlling the alpha carbons

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)
    1. Install Modeller
    2. Link to Modeller as an extension
    3. Download an easy to work with file 1TIMtr.pdb
    4. Restart Cinema 4D or other host
    5. Start ePMV
      1. You MUST leave the ePMV GUI open this entire session
    6. In the ePMV menu click Edit>Options
    7. In the options box:
      1. Uncheck [ ] everything
      2. Check [√] Synchro realtime
      3. Check [√] Use Modeller
      4. Click [OK]
        1. You'll see a new ePMV Null object with a little ePMV icon tag called epmvSynchro appear in your object manager
    8. Browse to find the 1TIMtr.pdb molecule you downloaded
      1. You cannot Fetch a molecule from the web to work with Modeller
      2. After browsing you should see 1TIMtrm as the name in your Object Manager when imported
        1. The "m" on the end means it has created and is using a Modeller modified version of the PDB file necessary to use the Modeller extension
    9. Set up an IK chain to keyframe a morph
      1. Check [√]Atoms and zoom in on your molecule
      2. Unfold Backbone Representations
      3. Leave the option on [>Trace] and check [√]Armature
        1. You should see a skeleton of joints appear at each alpha carbon
      4. Convert the armature to an IK chain with goals
        1. In the object manager, unfold 1TIMtrm and 1TIMtrm_Armature
        2. Right click on 1TIMtrm_Armature and click Unfold All
        3. In the hierarchy of the armature, command select every tenth joint, e.g., 1TIMtrm_A_LYS1_CA, MET10, LEU20_CA, SER30, PRO40, and ILE42
      5. Hold the command key and in the C4D menu, click Character>Commands>Create IK Chain
        1. This action should create 5 IK Goals at the top of your hierarchy manager with names that match the associated joints like 1TIMtrm_A_MET10_CA.Goal, no goal is created for LYS1
      6. Click the [-] next to 1TIMtrm_A_LYS1_CA in your Object Manager to refold the messy armature hierarchy, you should also refold 1TIMtrm_b_cpk, 1TIMtrm:A_ss, and 1TIMtrm:A_cpk to neaten up your Object Manager as well, this will be much less intimidating looking.
    10. Set up the Modeller extension
      1. In the ePMV Menu, click Extensions>Modeller
        1. If properly installed, you should see the Modeller GUI appear
      2. In the Modeller GUI do the following in order:
        1. Check [√] real-time
        2. Change [>mini] to [>md]
        3. Set number of steps = 2
        4. Change [>cpk] to [>bones]
        5. Check [√] display
        6. Click the [Update coordinates] button once
          1. If you have the Python Console open, you'll see a collection of Modeller parameters and results get updated in the console every time you click in the viewport or the playback head moves (don't move the head yet), This is good to confirm everything is working.
      3. Keep the Modeller GUI open
    11. In the C4D interface, lets experiment to make sure everything is working:
      1. Click Play- you should see your atoms start to wiggle
      2. Select the Null object 1TIMtrm_A_SER30_CA.Goal in your hierarchy manager
        1. With the Move tool, slowly pull this goal upward in your viewport, you should see the CA(alpha carbon) atoms move quickly and then all of the other atoms move to adjust as the MD minimizes the energies of the new structure you've created.
        2. Hit CommandZ to undo
        3. You can also grab an atom in the viewport and pull on it and watch the others try to keep up as the molecule relaxes.- very fun!
      3. After the atoms have returned to the original backbone (this just takes a few frames) push Pause
      4. Reset the playback head to frame 0
    12. Lets animate an illustrative morph between two conformations, one from the PDB and one you model by hand with the armature
      1. Select all 5 IK Goal null objects
      2. Next to the VCR like player in C4D, click the record key fame button (orange circle with a single key icon) to record positions for all 5 Goals at once
      3. To the left of the VCR buttons, change 90 F to 300 F to make a 300 frame scene
      4. Click the VCR >> to get to frame 300
      5. Grab your Goals, one at a time, and move them to create a radically different shape
        1. Don't worry that the atoms can't keep up- they have 300 frames to do that when you animate later
      6. Select all of the goals and click the record key
      7. Click in your Timeline to set the playback head to frame 60
      8. Click the Play backwards button < to relax the atoms as you head back to frame 0
        1. When you get near frame 10, you should hit pause and click the GoToPreviousFrame button one at a time until you get to zero... it take time for the playback head to stop and if you try to hit pause near frame 3, it will probably loop all the way to 300 before stopping.
        2. Your atoms should be relaxed to a conformation close to the original PDB file, but an MD relaxed version of that
      9. In the Modeller GUI, check [√]store
      10. In C4D, click Play > and be patient as ePMV stores 600 Modeller poses as:
        1. the IK chain morphs as it tries to reach your Goals
        2. the alpha carbons follow the centers of the joints in the IK chain
        3. the backbone atoms and side chain atoms get relaxed by Modellers default MD with 3 total steps for every frame of animation (seems to be one for the frame change itself and then two from Modeller behind the scenes- you may have a few extra frames from errant mouse clicks, etc.
      11. Click Pause when you get close to 290 and finish the last few frames with the GoToNextFrame Button in the VCR player
      12. In the Modeller GUI, uncheck store, display, and realtime and click the [Close] button
      13. In the ePMV GUI
      14. Uncheck [ ]Ribbons to clean up your viewport
      15. Unfold the Data Player
        1. Reselect 1TIMtrm in the drop down in the data player 
          1. It already has this selected as a bug, but you must reselect it to wake up the data player
          2. Your Step/value box should go to zero
        2. Scroll slowly through the step/value box to see your atoms move through the ~900 conformations, or click in different parts of the box to snap to each conformer
    13. Lets smooth out and speed up the animation and make it easy to render
      1. In the DataPlayer set the step/value box to 0
      2. In the Timeline, set the frame/playback head to 0
      3. Click Play and see that nothing happens
      4. Reset the frame/playback head to 0
      5. In the ePMV menu Click Edit>Options
        1. Check [√]Synchro Timeline
        2. Click the [OK] button
      6. In the VCR, click Play and see that it slowly marches through the conformation at a rate of 1 step per frame, so if you play to frame 300 you'll only get 1/2 way through your animation.
      7. Lets speed this up and make a 3 second animation of the conformational change
      8. In the ePMV menu Click Edit>Options
        1. Under Synchro timeline change steps every from 1 to 10
        2. Click the [OK] button
      9. Click Play and your atoms should conform completely in ~90 frames– it is playing every 10th snapshot of the ~900snapshot simulation for every one of your 90 frames
      10. Change 300 F to 90 F since there is nothing to see after ~frame 100
    14. Render the movie (temporary workaround)
      1. You can play the simulation and see it in your viewport, but if you render the movie, it only renders the first snapshot of the simulation.  We are working to fix this on June 22, 2012
      2. For now, the workaround is to keyframe the atoms manually- we will just do every 10th frame in this demo, i.e., every 100th snapshot.
      3. If you save your file, the connection to the epmvSynchro tag will be lost (another bug), you can overcome this by setting the snapshot you want to record in the data player rather than using the timeline (you'll see this issue if you press play after saving and your simulation doesn't move, but you can still move through it in the Data Player)
      4. Temporary Fix– Create keyframes for all of the atoms and let C4D interpolate)
        1. Deselect everything by clicking in a grey area of your object manager
        2. In the Object Manager, right click on 1TIMtrm:A_cpk (1TIMtrm>1TIMtrm:A>1TIMtrm:A_cpk) and choose SelectChildren
        3. Command click 1TIMtrm:A_cpk to deselect it so only the atom instances are selected
        4. Go to Frame 0 in your timeline
        5. In the palette to the right of your keyframe buttons, deselect Scale, Rotation, and Parameter, so only Position is blue
        6. Record a Keyframe
        7. Go to Frame 10 in your timeline (if your timeline is no longer synchronized to the data player, scroll in the data player to snapshot 100)
        8. Record a Keyframe
        9. Repeat steps 7 and 8 until you reach frame 90
        10. Play the movie:
          1. If you see atoms passing through each other, then move to the timeline in between those two keys (or equivalent location in the data player) and record another key
          2. Repeat as needed to avoid clashing atoms or to get as much or as little of the MD brownian dynamics motion that you want.
          3. If you want to render the entire movie, GotoFrame 0, click Automatic Keyframing button next to the keyframe button and push play, then pause at the end (this would create an insanely large and fragile timeline, so be careful)
    15. Note, you can guide the CA atoms using a spline as well.  The Spline Generated under Backbone representation puts anchor points at the centers of the CA atoms, and Modeller glues the CAs to that spline, so if you morph your spline between targets, the CAs will follow and Modeller will relax the rest of the atoms.
    16. We'll work to fix this clumsy workaround as soon as possible... may not be an issue in the other hosts.

Atomic Brownian Motion Fake with Bullet Physics

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)
    1. ePMV menu>Options: Change [>Secondary Structure] to [>None]
    2. Fetch 1crn
    3. Check [√]Atoms
    4. Hover over the viewport and hit H on your keyboard to zoom in to the molecule
    5. Reduce the geometry of the base atom
      1. In C4D object manager unfold 1crn, unforl 1crn_b, unfold 1crn_b_cpk, and unfold 1crn_b_cpk_shape
      2. Select the base atom sphere 1crn_b_cpkbasesphere which is now visible in the Object Manager
        1. Set Segments = 12
        2. Set Type = Icosohedron
      3. Right click on 1crn:A_cpk and select Simulation Tags> Rigid Body
      4. Push the Play button in your VCR-like TimeLine controller
        1. Your molecule should fall downward as an established unit
      5. In the Attributes manager for the tag you just created select the Collision Panel:
        1. Set Inherit Tag = [>Apply Tag to Children]
      6. Add a Floor Object
        1. C4DmainMenu>Create>Object>Floor
      7. In the Object Manager, right click on the Floor and select Simulation Tags> Collider Body
      8. Push Play to watch the atoms burst apart onto the floor
      9. Select the Rigid Body Dynamics tag you made that is attached to the 1crn object
      10. In the Attributes manager for the tag you just created select the Force Panel:
        1. Set Follow Position = 40
        2. Set Follow Rotation = 40
      11. Push Play, the atoms burst apart, but try to get back to their original position
      12. Push Pause and Rewind to Frame 0
      13. In the Attributes manager for the tag you just created select the Collision Panel:
        1. Uncheck [ ] Self Collision
      14. Push Play
        1. The molecule falls a small amount because its fighting gravity but working to get back to its original position
      15. Turn off Gravity
        1. C4DmainMenu>Edit>ProjectSettings>Dynamics Tab: 
          1. Set Gravity = 0
      16. Rewind then push play and nothing should move
      17. IN PROGRESS

Animate a ribbon model with inverse kinematics using joints

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)  This is a temporary rough version with minimal instructions
  1. Make an ePMV armature for CAs
    1. Backbone Representation>[√]Armature>Trace
  2. Make an ePMV ribbon
  3. Select all of of the ribbon geometry and "click" Objects->Connect
  4. This action should leave the newly connected geometry selected
  5. Add all of the joints in the armature to the current selection (mesh and joints must be selected at the same time)
  6. Click Character->Command->Bind
  7. Select every ~10th or 20th joint in the armature (depending on the size of the chain)
  8. Click Character->Command, and hold the control key while clicking Create IK Chain
  9. This creates Goals for each of the selected joints.
  10. Grab a goal, pull it around, reset with undo then animate the goal or apply some simulated motion to it.


Make a 13 protofilament microtubule

These Cinema4D-specific instructions are generalizable to skilled users of other host software like Maya and Blender)  This is a temporary rough version with minimal instructions
  1. Download the structure of Nod bound to a 13 protofilament microtubule which is EMDB id 5038
    1. This structure has a non motile kinesin (Nod) docked into it and we will merge the two files in ePMV
    2. Windows users may need to install an unzipping freeware package
  2. Once uncompressed, change the name of the downloaded file's .map tag to .ccp4 so the precise file is named emd_5038.ccp4
  3. Start a fresh ePMV session
    1. In the ePMV menu click Edit>ePMV Preferences
      1. Uncheck [ ]Center Molecule to Origin
      2. Change Default Representation: CMS
      3. Click Apply and Close
    2. Fetch 3dco
    3. Adjust the surface representation to something comfortable e.g., 7.0, -0.15, 16
  4. Generate a reference mesh and use your host software's duplication/instancing system to generate a repeated helical structure.
    1. Unfold >Data Player
      1. Browse and load the emd_5038.ccp4 file
        1. This may take a minute and will require 64 bit software on most machines because it generates a lot of polygons by default.
      2. Click and drag to reselect emd_5038 in Apply emd_5038.ccp4 to current selection... to initiate the data slider
      3. Change 0 to 1 and hit return to get a good mesh.
  5. Replicate the coarseMolSurface representation you made of 3dco to recreate the helix
    1. This version will use Cinema 4D's mograph to efficiently instance the geometry- apply similar settings in your host (Maya, Max, Soft, Blender, etc.)
      1. Create an instance of only the cMS geometry so we don't replicate any other high-object/polygonCount structures you may have generated with ePMV for 3dco
        1. In the C4D Object Manager:
          1. Unfold 3dco
          2. Select CoarseMS_3dco
        2. In the C4D main menu: Create>Modeling>Instance
          1. This will generate a new instance of CoarseMS_3dco
      2. Replicate 1 full helix of the instance:
        1. C4D main menu: Mograph>Cloner
          1. This will create a new Cloner object called "Cloner" in your object manager
        2. Rename Cloner to "MT_one_negative_turn"
        3. Drag the instance CoarseMS_3dco onto this new cloner so it becomes a child of MT_one_negative_turn
        4. Select MT_one_negative_turn and in the Attributes menu that now shows, set:
          1. Mode: Radial
          2. Count: 13
          3. Plane: ZY
          4. End Angle: –360º
        5. You should now see a ring of 13 copies of 3dco which has a tubulin dimer and the Nod bound to it
        6. Offset the ring to generate a helix:
          1. We are building the helix "backwards" i.e., towards the (-) end of the microtubule (opposite of the direction that kinesin I and kinesin II walk because the authors docked the Nod from 3dc4.pdb well towards the plus end of their 3D volumetric map, so if we try to extend our helix "forward" towards the plus end, i.e., the direction that the helix is most quickly assembled (the dynamic tip), our single helix will run off of the map and be hard to visually analyze.
          2. With MT_one_negative_turn selected, click C4D main menu: Mograph>Effector>Formula
            1. We will use a formula effector to modify the helix
            2. Your scene will change dramatically, but we will fix it
          3. Object manager: Select Formula
            1. Attribute Manager for Formula:
              1. Effector Tab: Change Formula to read only "id"
              2. Parameter Tab: Uncheck [ ]Scale
              3. Parameter Tab: x = -9.231
                1. This value comes from one helical turn progressing 12nm along the axis of rotation from the papers:
                  1. http://jcb.rupress.org/content/102/3/1067.full.pdf
                  2. http://www2.mrc-lmb.cam.ac.uk/groups/jyl/PDF/Amos%26Schlieper.pdf
                  3. i.e., -120Å/13rotations = -9.231Å/rotation along the axis of rotation which is X in C4D with ePMV (this axis will be Z in the other hosts which have a more common right-handed world coordinate system)
        7. Extend the microtubule by replicating this single turn of the helix
          1. C4D main menu: Mograph>Cloner
            1. This will create a new Cloner object called "Cloner" in your object manager
          2. Rename Cloner to "MT_axial_repeats"
          3. Drag the older cloner MT_one_negative_turn onto this new cloner so it becomes a child of MT_axial_repeats
          4. Select MT_axial_repeats and in the Attributes menu, set:
            1. Count: 8
            2. X = 80
            3. Y = 0
              1. This should generate a repeat of the helix that fits perfectly into the 13 protofilament volumetric map, i,e., you have just generated an efficient C4D native mograph model of a high resolution structure that fits cleanly into the experimentally derived data of the electron microscopy 3D map!
      3. Clean up the model to separate the microtubule surfaces from the Nod surface and reduce the number of Nods:
        1. Create one molecular surface and one coarse molecular surface for each of the 3 chains as well as one for the entire tubulin dimer:
          This will give many options that you can mix and match to create the ideal surfaces for your microtubule vs your kinesin
          1. Create One of each type of surface for each chain:
            1. Unfold "PMV-Python Scripts/Command"
              1. Select: "Surface_per_chain
              2. Change #molname = "2plv"  to    #molname = "3dco"
              3. Click Execute
                1. Depending on your view angle, you may not yet notice a change as the surfaces were generated in a part of the hierarchy that was not instanced into the extended microtubule, but under 3dco in the object manager, 8 new meshes have been created
          2. Create a single cMS for the tubulin dimer:
            1. Unfold the ePMV Selections group
              1. Set Current Selection to 3dco
              2. In the Object Manager, select 3dco and type F on your keyboard to zoom in, adjust the view to easily see the base meshes
              3. Paste chain A,B into the box and check the [√]Show button
                1. White +'s should indicate that only the tubulin chains are selected (not the N chain)
              4. Click and drag {>Save Set} to read Save Set
                1. This will save a selection set now visible under Current Selection:
              5. Select the new selection set by setting Current Selection = 3dco_Selection0
                1. Now changes you make to the representation buttons will only apply to this selected set of atoms (the tubulin dimer)
            2. Make a coarse MOLecular SURFace of the tubulin dimer:
              1. Check [√]coarseMolSurf
        2. Now, repeating the standard C4D instancing steps described above, you can select which surfaces to put into the helical cloner (e.g., just the new tubulin dimer coarseMolSurf, or a group (null object) with just the two tubulin monomers), then you can either duplicate the helical cloner and put only the Nod inside with a bunch of Nulls to spread it out, or have only the one original Nod.
    2. Add conventional kinesin as described in http://www.ncbi.nlm.nih.gov/pmc/articles/PMC2765580/
Colorize Lipids using the selection:
topgl:::C1,C2,C3,C4,C5,C6,C7,C8,C9,C10,C11,C12,C13,C14,C15,C16,C17,C18,C19,C20,C21,C22,C23,C24,C25,C26,C27,C28,C29,C30,C31,C32,C33,C34,C35,C36,C37,C38,C39,C40,C41,C42,C43,C44 
to select isolate all of the tail carbon atoms, then colored the tail atoms yellow, and colorized the surface blue with the tail atom surface light grey.





Comments